Bchex - Aegis Outage Detected – Incident details

All systems operational

Aegis Outage Detected

Resolved
Major outage
Started 3 months agoLasted 3 minutes

Affected

Aegis Website

Operational from 4:51 PM to 4:51 PM, Major outage from 4:51 PM to 4:54 PM, Operational from 4:54 PM to 4:54 PM

Updates
  • Resolved
    Resolved

    😅 Phew! Aegis is back up and operational. Thanks for waiting on us to get things back on track. 🚀

  • Investigating
    Investigating

    😬 Yikes! Aegis is experiencing technical difficulties. Our team is on it, actively working to resolve the issue as quickly as possible. This page will update regularly with new info, and automatically once back online. If you subscribe to these notices, we will keep you looped in. Thank you for your patience!